The Form Spins Forever on Submission and Does not Show Confirmation Message

Hello,

I have multiple forms present on my website and all of them are having this issue. When user fills all the data and clicks on the submit button, the form keeps showing the spinning icon and does not proceed to show any confirmation message.

I have made a staging website and disabled all plugins and theme. The WordPress has been reinstalled to make sure it is clean and latest version. PHP Version is 8.1. Gravity forms is up to date and there is no error or warning present in the plugin admin pages. The PHP Resource limits are above than the minimum requirements

Link to the Staging URL:
https://sp-wpharbor628.e.wpstage.net/contact-custom-plastic-injection/

The website is password protected. You can access the website with below mentioned authentication login:

Username: blogvault
Password: e27ec61d

Please let me know if you want me to share WordPress admin logins.

Thanks.

1 Like

This is system generated report:

Gravity Forms

Version: 2.7.12 :heavy_check_mark:
Upload folder: /var/www/html/site/public_html/wp-content/uploads/gravity_forms/
Upload folder permissions: Writable :heavy_check_mark:
Output CSS: Yes
Output HTML5: No
No-Conflict Mode: No
Currency: USD
Background updates: Yes
REST API v2: No

Database

Database Version: 2.7.12 :heavy_check_mark: Your database is up-to-date.
wphs_gf_form_view: :heavy_check_mark:
wphs_gf_form_meta: :heavy_check_mark:
wphs_gf_form: :heavy_check_mark:
wphs_gf_form_revisions: :heavy_check_mark:
wphs_gf_entry: :heavy_check_mark:
wphs_gf_entry_meta: :heavy_check_mark:
wphs_gf_entry_notes: :heavy_check_mark:
wphs_gf_draft_submissions: :heavy_check_mark:

Translations

Site Locale: en_US
User (ID: 13) Locale: en_US
Gravity Forms:

WordPress

Home URL:
Site URL:
REST API Base URL:
WordPress Version: 6.3 :heavy_check_mark:
WordPress Multisite: No
WordPress Memory Limit: 128M
WordPress Debug Mode: No
WordPress Debug Log: No
WordPress Script Debug Mode: No
WordPress Cron: No
WordPress Alternate Cron: No
Background tasks: No ✘ Response code: 401

Active Theme

Twenty Twenty-Three: by the WordPress team (https://wordpress.org) - 1.2 :heavy_check_mark:

Web Server

Software: Apache/2.4.29 (Ubuntu)
Port: 443
Document Root: /var/www/html/site/public_html

PHP

Version: 8.1.12 :heavy_check_mark:
Memory Limit: 512M
Maximum Execution Time: 60
Maximum File Upload Size: 50M
Maximum File Uploads: 20
Maximum Post Size: 100M
Maximum Input Variables: 1000
cURL Enabled: Yes (version 7.58.0)
OpenSSL: OpenSSL 1.1.1 11 Sep 2018 (269488143)
Mcrypt Enabled: No
Mbstring Enabled: Yes
Loaded Extensions: Core, date, libxml, openssl, pcre, zlib, filter, hash, json, Reflection, SPL, session, standard, sodium, apache2handler, mysqlnd, PDO, xml, apcu, bcmath, bz2, calendar, ctype, curl, dom, enchant, mbstring, FFI, fileinfo, ftp, gd, gettext, gmp, iconv, igbinary, imagick, imap, intl, ldap, exif, msgpack, mysqli, pdo_mysql, pdo_pgsql, pgsql, Phar, posix, readline, shmop, SimpleXML, soap, sockets, sysvmsg, sysvsem, sysvshm, tidy, tokenizer, xmlreader, xmlrpc, xmlwriter, xsl, zip, zmq, memcached, ionCube Loader, Zend OPcache

Database Server

Database Management System: MariaDB
Version: 10.1.44 :heavy_check_mark:
Database Character Set: utf8mb4
Database Collation: utf8mb4_general_ci

Date and Time

WordPress (Local) Timezone: America/Detroit
MySQL (UTC): 2023-08-16 19:22:12
MySQL (Local): August 16, 2023 at 3:22 pm
PHP (UTC): 2023-08-16 19:22:12
PHP (Local): August 16, 2023 at 3:22 pm

Having the same issue with all of my sites. HELP!

Is there anything in your server’s PHP error log?

Does the submission complete if you set the form notifications to inactive?

GoDaddy has a known issue with the PHP mailer on their servers, it’s taking over 300 seconds to respond, which makes it look like the submission has stalled or timed out. The issue is also impacting other hosts who use GoDaddy servers.

It does compete the submission with notifications off. I contacted Godaddy this morning and they are working on the issue.

Sandra Squires

Capra Strategy

I am having this same issue as well, and my hosting is GoDaddy. Has anyone found a solution to this yet?

Until GoDaddy resolves the issue, you could:

I tried multiple servers but getting same issue. I am using Liquid Web hosting server. Error log file is present on below mentioned link but it does not show any issue with respect to gravity forms.
https://sp.wpharbor.com/PHPErrorLog.txt

The form submissions didn’t work even when I deactivate notifications. No clues what to do now. Please get back to us.

Have you tried testing with logging enabled?

Setting the notifications as “inactive” worked just fine. Thanks for the tip!

Logging has been enabled and I have tested submissions after enabling logging of Gravity Forms. I didn’t notice any issues in the log file after making multiple failed attempts. Please check below mentioned error logs:

2023-08-17 15:13:30.784132 - DEBUG --> GFCommon::post_to_manager(): endpoint: https://gravityapi.com/wp-content/plugins/gravitymanager/message.php?of=GravityForms&key=9274dcb009b0b69bbfad3177490b122d&v=2.7.12&wp=6.3&php=7.4.33&mysql=10.5.22&version=2 


2023-08-17 15:13:30.906315 - DEBUG --> GFCommon::log_remote_response(): code: 200; body: <!--GFM--> 


2023-08-17 15:13:30.940917 - DEBUG --> Gravity_Api::check_license(): getting site and license info

Those aren’t form submission logging statements, they are license validation and update check logging from accessing the system status or settings pages.

Can you open a support ticket with the full system report and log links at: https://www.gravityforms.com/open-support-ticket/technical/

I have submitted ticket there.