My forms just don't display after latest update to 2.5.5.1

Hey all, so I run several forms on the site, I’ve checked that they’re all active and have the correct field ID etc… but since the latest GF update, now only one of my forms actually displays.
So you click on the form you want to fill out and it just stalls at the landing page, doesn’t actually display the form at all.
GF help has said to check theme conflicts but I admit it’s a bit beyond me, and everything was fine until most recent update.
Any ideas?

Hi I had the standard answer form GF about conflict with theme/plugin etc

The only work around was to switch off my cacheing optimiser and this has worked.

I reported the issue yesterday AM for UK and still no update. I am unimpressed by GFs responses, and lack of solution.

Yes have the same issue “everything was fine until most recent update.”

Turn off any conditional fields and “enhanced views” and it will likely show. Both appear to be broken.

Thanks, I’ve deactivated the cache and will see what happens. Weirdly some forms are now working but others aren’t, like the bug or glitch is moving around. I’m no web expert I know that’s probably the wrong way to phrase it but anyway.

© 2008 - 2019. Gravity Forms is a project by Rocketgenius Inc.