Gravity Forms Is using admin email for sending emails – "from" address in form config is ignored


we’ve got the following issue: every form notification on our website is always sent from our admin email address which is set in the settings of Wordpress although we have set different “from addresses” for the form notifications, the mails are always sent via our admin email address (and “from name” is always our site name, which also shouldn’t be the case).

So basically the setting “from address” and “from name” in the notification settings is being ignored within the sending process of the notification mail.

I already deactivated all plugins and activated the twentytwenty standard theme to test it again. The issue then did not occure. It means that something in our own theme isn’t quite right. The thing is, the problem’s only been around for about a week and we did not change anything according to the mail sending process.

It would be great if someone maybe has a tip or something. Are there any functions that can cause this by accident?
Thanks in advance!

There is the gform_notification filter which can be used to control this, but it’d be odd that your theme might be implementing this. Did you isolate it to the theme or could it be one of the plugins? I use WP Mail SMTP to send messages from my site. That plugin, as I expect other mail plugins, has a setting to force sending messages from a specific address. Could you have something like that in play?

Thanks for the reply Joshua. I did isolate the issue to the theme, yes. Using SMTP would’ve been our next approach to this – we’ve not done that yet on the site. I already checked for used Gravity Form hooks that might have been used in the theme somewhere but I didn’t find anything.