From shows and then the name we filled at the form

Hello, we’ve changed the From address to a customized mailaddress from the website domain. However, when the client receives a copy, it states the mail is from ‘’ and then the name and customized mailaddress.

How could we remove the ‘’ part so that only our customized name and mailaddress show?

Thanks in advance!

Hello. You can change the FROM address on the Notification itself. The option looks like this:

If you change it there, but the email still arrives with a different FROM email address, your mail server is changing that, and you would need to contact them for support.

Hello Chris,

Thank you for your quick reply. We’ve changed the address at the notification option.

However, it looks like this when the mail arrives:

The part is there and then it states “namens” (on behalf of) and then the part what we filled in at the notification settings.

Also, in this case we have to assume it’s the mailserver causing this?

Thanks very much for your confirmation.

Best regards,

The “on behalf of” is added by some mail providers (like Google/Gmail.) That is normally when you are sending from an email address that is not authorized to send through another server. This is a DNS setting with either SPF or DKIM (and possibly DMARC.) Those topics are outside of the support we can offer, but if you have set the FROM address to one address and the email arrives from another, the issue is not with Gravity Forms.

You may want to consider one of our three dedicated mailing add-ons which can help you with some of this:

Also, I have had good luck using Sendinblue with an SMTP plugin. Here’s a great SMTP plugin you can use (there are many in the WordPress plugin repository):

And here is Sendinblue:

I like Sendinblue these days because they have a free plan with 300 email messages per day allowed. The next closest is Sendgrid with 100 free messages per day.

You can also contact Gravity Forms support if you need assistance with setting this up:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.