Form data not passing to next step after submission [RESOLVED]

I have a form recording client contacts in which, using Populate Anything the user can select other members of the organization as the contact they identified first. First time worked perfectly with Gravity Perks Google submission. After the first time it does not pass. I thought maybe it’s because the Gravity Perks was beta it’s just screwing up. But I have the same problem with passing to Zapier with a webhook. What should be an afterthought is taking up my whole morning chasing this down. What causes data that shows in the entries table to not appear when sending it to an application?

Have you tried testing with logging enabled to see if the add-on logs have any errors recorded for the submissions?

Thanks for this. I submitted another form with logging on and am trying to decipher the info. Wondering if the left hand knows what the right hand is doing. There appears to be a time-out. The values off the checkboxes are for a field using Populate Anything. Might I need to process the data a bit and get the values into a static field saved on WordPress? Seems that would be the case naturally (hope I’m making sense.) Who should I send the log to?

Thanks for the interaction. I solved it using the copycat perk. Even though there should be a hard value in that field this gives me a hard value that works when passing the data along.