2.5.5.1 reintroduced missing form with conditional fields

This was fixed at 2.5.5 but is now back. What is a work around? I can’t keep going back and forth. Yes, already opened a ticket and was told to put in troubleshoot mode and that it was a plug-in conflict. It’s not, it is absolutely GF.

1 Like

The best place for your issue to be resolved is with Gravity Forms support:

Follow up with that support ticket you opened. If you would like me to check on the ticket, please share the support ticket number here. Thank you.

Yes, can confirm the problem here as well. As long as there is one conditional field, the whole form is set to display:none.

It’s caused by line 957 in form_display.php.

Please fix this asap. All our forms with conditional logic are not working anymore now.

1 Like

Hi Chris, Can I echo the comment of Roel van Leuken, every form with conditional logic is now dead on many of ours sites. Can we have a fix ASAP please, I’ve one site with over 20+ forms no longer working since the update. This is urgent please you need to get an update out asap.
Thanks
Martin

1 Like

Can I add to this request please. I have lodged a support request.

Loss of functionality is causing us issues.

Thnaks

Michael

Anyone having an issue with conditional logic with the latest Gravity Forms release please open a support ticket so that the product team is aware of the issues you are having:

Thank you.

+1 here. Opened a ticket.

2 Likes

Well, opening a ticket was a complete waste of time. I’m being told it’s caching issue even though it 100% is not. I’ve now been told to install a different caching plugin than WP Rocket, even though we disabled WP Rocket during the three goddamn hours I spent troubleshooting this issue before realizing it was a GF issue. Does anyone have a workaround for this issue yet?

1 Like

This is why I continue to come back to this forum. I appreciate Chris’s notes to open a ticket. I know that is direct support rather than community but also helps secure their licensing model. However, we are a very small non-profit and have the Elite License which is nearly half of our website budget and don’t have time to wait an hour between responses.

The Support responses equate to telling me to reboot my PC. This is clearly an issue on GF side. The changelogs clearly reflect that and yet the support desk does the “troubleshoot mode” and “it’s caching” etc. Please own up to it and lets get to a resolution. I am willing to participate in a solution.

For now, I luckily found 2.5.1 on my machine and it is working fine for me. Down grading was no issue either.

Even with EVERY plugin disabled, no cache and swapping to the standard WP 2021 theme I still cannot use a single gravity form with a conditional field. Has anyone found a fix yet? I have clients losing money on this and I’m not impressed with support pretty much ignoring the list of things done to implement a fix or workaround.

1 Like

I also debugged this, I think a temporary fix for this is adding this to functions.php of your theme:

add_filter(‘gform_has_conditional_logic’, ‘__return_false’);

We have about 50 websites using Gravity Forms, so it’s not doable to do this for all our websites. I hope they will release a fix anytime soon!

Can you send this to support? This was the last update from them about an hour ago.

I can’t replicate any issue with forms using conditional logic in a default WordPress installation. You will need to perform a full conflict test to find out what’s causing the conflict in your site, disabling only a few plugins is not a valid conflict test. You will want to follow all the recommendations in this guide: [Testing for a Theme/Plugin Conflict using the Health Check & Troubleshooting Plugin - Gravity Forms Documentation]

Regards,

If I’m not mistaken, that workaround just disables the functionality of conditional logic. So I’m not sure if that’s a workaround.

I’m having this same issue on a form with conditional logic. It worked fine with 2.5.4 and I accidentally had auto updates enabled. Now, the form just shows blank, even in preview. I’ve contacted support and all they say is it’s a caching issue. It is not. The exact same thing happened on my staging site that has no caching at all. Even if they would just provide 2.5.4 I could roll it back. But, they refused to do that, too. So, I guess I’m stuck now? The disabling of the conditional logic didn’t work for me either. Come on, Gravity Forms, we need a fix for this.

I think this is actually a cache issue of some sort. What other caching plugins are people using? We use WP Rocket and I realized it was cache issue when I cloned my site so I could do some testing. We have never been able to duplicate this issue in a browser, possibly because are are only using a single conditional logic to hide a recaptcha for form testing we do. Once cloned, our form test (via Deep Web Monitor) worked on the new site once and then never again. Once I purged all caches and disabled WP Rocket, I was able to test it numerous times without fail. So for now I’ve told WP Rocket not to cache on the page where the form is, but that’s really not a permanent solution. I’ll also reach out to WP Rocket to see what they say. Is anyone seeing this and not using WP Rocket?

It’s not a cache issue. I tested on a site with no caching enabled. I did, however, find my plugin Disable XML-RPC-API is the culprit. I went through and disabled them one by one and found this was the conflicting plugin. Hope that helps GF to provide an update to allow them to coexist.

Yep, this is happening to me. Have tried disabling all plugins, didn’t resolve anything. Have turned off caching no help. Will open a ticket.

EDIT:
I just opened a support ticket and got the issue sorted within 30 mins.

I was calling in a form using the PHP gravity_form function below wp_footer(). Moved wp_footer below the form and it is working again.

I just experienced this, where only forms with conditional logic had disappeared, and opened a ticket. Support answered right away. While troubleshooting, I found that if I turned off the Autoptimize plugin, my forms re-appeared. If I turned it back on, they disappeared again. I purged the Autoptimize plugin but that didn’t work.

So next I left Autoptimize active, but then went and purged our Cloudflare cache, then re-purged Autoptimize cache, then purged the server cache (at the host) and then finally cleared all my browser histories - in that order. The forms all re-appeared!

Seems to be caching of javascript files of Gravity somehow I think (the form, when using conditional fields, is hidden by default and re-appears with some javascript logic it seems). We’re using Litespeed caching. The caching seems to be really persistant. At first disabling Litespeed didn’t fix the issue, but I tested again and purging the Litespeed cache fixes it now.

Same problem here.
I do hope they solve this asap.
We have tons of websites with many many forms that have conditional logic attached.

(I tested it with a new form without conditional logic and it is showing without any issues)

We use WP Rocket/Autoptimize as well.
Deleting/purging cache didn’t help here.
If someone has a different solution, feel free to share.

© 2008 - 2019. Gravity Forms is a project by Rocketgenius Inc.