Valid form entries marked incorrectly as SPAM - how to switch off GF spam filter?

hi there, wondering if anyone can help… my client is experiencing her valid form entries being incorrectly directed into the SPAM folder and therefore since she isn’t getting a notification of the form’s existance, she is missing important communication from her users. Other than having to remember to manuallly check the SPAM folder very regularly I can’t see a way to permanently switch off the GF spam filters.

Incidentally we do not have Akismet installed on this site, which from what I can see if what GF uses to filter SPAM so i can’t see what else might it be using in it’s absence? Has anyone else experienced such false positives and found a way around it?

Hi Gaby,

It is possible that the problem you are experiencing with sending emails and going to the spam folder is due to an issue with your email or hosting server. To resolve this, you can consider using third-party solutions like SendGrid or SendInBlue.

To further assist you, I recommend checking out the following article:

Additionally, you may find this plugin helpful:

We have also been informed that Gravity Forms will be introducing its own SMTP solution. For more information:

Give it a try, and let me know how that goes! :smile:

Hi thanks for your reply. I don’t have any problems with emails sending. I already use WP Mail SMTP. My problem is that valid form entries are being flagged as Spam by GF and directing them into the GF spam folder. This means that the front end user doesn’t get notification of form confirmation success and my client doesn’t receive notification of form submission.

It might that you have the honeypot field enabled in the form settings. This normally works well, but there’s two ways it can result in all entries being flagged as spam.

First and most likely: each time you update Gravity Forms, it generates a new honeypot key. If you have a page cache, your visitors will be submitting entries with an old honeypot key until you clear the cache. It’s very important to clear the page cache when updating Gravity Forms (and a good idea with other plugins).

Second: if there’s a JavaScript error on your page, it can break the honeypot JavaScript and the entry will submit without the necessary hidden field. Check your page with the browser console open and the Console tab selected, to see if there’s any JavaScript errors. Hit F12 key to show the browser console.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.