User Registration Plugin Showing email Instead of First Name in Update User Form

I am running two versions of the same website. One is local. One is on a public facing site. The public site is password protected, so I can’t link to it here.

I am attempting to create an Update User form using the User Registration add-on. I have added a form using the code below:

<?php gravity_form( 2, false, false, false, null, true ); ?>

The form that I’m using has the same ID on both sites and is displaying. The problem I’m having is on the live site the first name field is auto-populating the email address. On the local site, the first name is exhibiting the desired behavior of auto populating the first name in the first name field.

Things I have checked so far:

  • The users in both local and live have distinct first names and display names from their email
  • I have copied all form settings from the local DB to the live DB to make sure the forms are exactly the same. The meta data is exactly the same for both forms. I also copied the gf_addons settings to make sure it’s the same for both.
  • The WP version and all plugins are installed the same and at the most current version.
  • PHP version is the same.
  • Copied the entire codebase from the local site to the live site to ensure they are the exactly the same

I have to be missing something. What did I do on the local site different that the live site? Any direction or ideas would be very helpful.

The Update User feed mapping controls what is displayed in the form when it’s rendered for the logged-in user. If those mappings are correct on the live site, something else populates that field with the email address. Is it possible it’s browser autocomplete? Or caching on the live site?

I checked autocomplete by opening the page in a browser that has no autocomplete information and is in incognito mode. No change.

There is not site caching.

Good thoughts.

I recommend opening a support ticket in this case:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.