Post Body field (rich text editor) tabindex skipped on form entry using keyboard tab

Hello Gravity Community!

I need some help with an issue regarding the Post Body field rich text editor tabindex. During form entry and using tab key, it is skipped and only the hidden textarea(mask field) field has the tabindex value. I’ve tried the filter “gform_rich_text_editor_options” and set the tabindex value but still doesn’t work.

Looking forward for a workaround.

Thank you,

I can’t replicate the issue in a default WordPress installation. I would recommend you to perform a full conflict test following the instructions here.

Thanks for checking out @sacom and the suggestion.

I’ll attach a screenshot of the DOM

To my surprise, leaving the form widget(Elementor) tabindex setting to empty or zero value works fine with tab key. Tried tabindex 1000, won’t work. Not sure if it’s still an index conflict with other fields but would love to be able to set the tabindex value. Might be useful in some cases.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.