CAPTCHA not showing on form

Hi, on my contact form at vector3d.co.uk/contact the CAPTCHA doesn’t show up, so the user cannot check the box, so the form cannot be submitted.

It was working initially, then I tried changing to the hidden version that doesn’t need a check box, that didn’t work so i switched it back in the settings (i double checked this) and now it doesn’t show at all and the form fails.

Hi Adam. There are three common reasons that the CAPTCHA will not show on a form.

  1. You have embedded the same form more than once on a page. That is not true for you.
  2. There is a conflict with another script on the page (let’s skip that for now, but if you want to check for conflicts, you can use these steps)
  3. Caching. Your page is cached, which is probably what is causing the issue with the reCAPTCHA scripts.

We recommend excluding pages with forms on the from caching. Depending on the caching solution you are using, you may be able to exclude this one page and other pages with forms on them.

Or, some plugins can do this as well:

or

Please exclude this page from caching, and see if the CAPTCHA appears. Let us know what you find out. Thank you.

Thanks for the response.

I’ve installed the Fresh forms plugin and the issues seems to still persist so looks like it’ll be problem 2 which is a bit more involved.

Before i go through that, I’ve noticed that the Captcha seems to show up when logged in, but otherwise it’s hidden. Does this provide an additional helpful clue in diagnosis?

If the CAPTCHA shows up when logged in but not when not logged in, the issue is almost always due to caching. That is because the logged-in visit is not typically cached, but public visits to the site are.

Are you using the reCAPTCHA add-on (V3 CAPTCHA) or the built-in v2 CAPTCHA either invisible or checkbox (where you add a field to the form)?

Ah ok interesting. Im using built in V2. It’s set to checkbox, and the api key thing from google is also for checkbox and i’ve added the item to the form.

I did switch it to invisible at one point, it stopped working then because of wrong api key, I got the invisible type api key, then decided it was confusing for it to be invisible and went back to checkbox with another key for that.