Zapier Authentication

I have been struggling to connect Zapier to gravity forms in my multisite setup for the last 2 hours. I kept getting this error in the Zapier connect window:

We hit an error adding your new account authentication failed: Invalid Base URL.

Activating the GF logs showed both these errors:

ERROR –> GF_REST_Authentication::perform_basic_authentication(): Aborting; credentials not found.
ERROR –> GF_REST_Authentication::perform_basic_authentication(): Aborting; user not found.

The solution I found was this - Fix Site Health Error: The authorization header is missing | Digging Into WordPress.

In particular under Tools >> Site health in the Wordpress admin I was seeing:

The Authorization Header is missing

Replacing the default Wordpress .htaccess info fixed it for me:

It must have corrupted (maybe with security plugins) or I might have even manually edited it incorrectly. Anyway this fixed it. Hope this helps someone if they experience the same…

1 Like

HI Jason,

Thank you for sharing your experience. This is one of the first tests we have users perform (checking the Tools > Site Health for errors) if they’re not able to connect to Zapier when you open a ticket with us.

We have some fairly good links within that document that help with troubleshooting issues with the Authentication Header or if Basic Authentication is not working.

I’ll look at incorporating that article into our Troubleshooting Guide.

Thanks again!

1 Like