Stripe : no API Key fields since update, only "Mode" & "Connect with Stripe"

Hello,

Since last update, I cannot use anymore STRIPE because I cannot enter API Keys.
error_stripe
I Can Connect to stripe, but still no fileds to enter API keys.

I have WP 5.9.1 GF 2.5.16 STRIPE addon 4.2

Also received this error from WP :

Une erreur de type E_ERROR a été causée dans la ligne 221 du fichier /home/www/wp-content/plugins/gravityformsstripe/includes/stripe/stripe-php/lib/BaseStripeClient.php. Message d’erreur : Uncaught Stripe\Exception\InvalidArgumentException: api_key cannot be the empty string in /home/www/wp-content/plugins/gravityformsstripe/includes/stripe/stripe-php/lib/BaseStripeClient.php:221
Stack trace:
#0 /home/www/wp-content/plugins/gravityformsstripe/includes/stripe/stripe-php/lib/BaseStripeClient.php(59): Stripe\BaseStripeClient->validateConfig(Array)
#1 /home/www/wp-content/plugins/gravityformsstripe/includes/class-gf-stripe-api.php(55): Stripe\BaseStripeClient->__construct(Array)
#2 /home/www/wp-content/plugins/gravityformsstripe/class-gf-stripe.php(4948): GF_Stripe_API->__construct(’’)
#3 /home/www/wp-content/plugins/gravityformsstripe/class-gf-stripe.php(4789): GFStripe->include_stripe_api(‘test’, Array)
#4 /home/www/wp-content/plugins/gravityformsstripe/class-gf-stripe.php(5759): GFStripe->get_stripe_account(Array, ‘test’)
#5 /home/www/wp-content/plugins/gravityformsstripe/class-gf-stripe.php(1009): GFStripe->is_stripe_auth_valid(Array, ‘test’)
#6 [internal func

Any idea of problem ? Thanks

Hello Paulo. When you connect with Stripe using the button, you are authorized with OAuth, and there are no API keys to enter. Once connected, you should see the name of the Stripe account you are connected to, and the button should change to “Disconnect your Stripe Account”. If you still see “Connect with Stripe” you are not connected.

If you need assistance with this, please open a support ticket here:
https://www.gravityforms.com/open-support-ticket/technical/

Still the same problem after login
error_stripe2

When I try to create a stream on a form with stripe :

To get started, please configure the stripe settings

Ok I will open a ticket. Thanks