Stripe Authentication Issue [RESOLVED]

Hello! I’m trying to connect a Stripe account, but it’s not saving to my GravityForms installation after I come back from Stripe’s authentication sequence at


I’ve tried:

  • Connecting different Stripe accounts (one that’s not verified, one that’s authenticated, one that’s taken payment)
  • Different browsers (Chrome, Safari)
  • Incognito on/off
  • Making a support ticket (recently, still waiting on a response)

Update - I have re-installed the extension; no dice.

I had the same issue. If it asks you to relogin to your wordpress account once it returns to your site you need to do it again.

I logged out of wordpress and then relogged in and tried again. Not sure if this would work for you

Doesn’t seem to be working, @user5f5954feca2d7796. Thank you for the tip nonetheless :slight_smile:

I think there was a minor release of the Stripe add-on that fixed this – or maybe a related issue. Check in your GF account dashboard to see if you have the most recent version.

Solved! For the next person who runs into this and wants to punt something across the room, a mixture of the two responses here fixed it. I deactivated and deleted the add-on, then downloaded from the account dashboard - not from add-ons page in my WordPress installation.

Following an attempt to connect, I went through what James Hill was experiencing, where it was logging you out. I logged out and logged back in, and that solved it.

Thank you both!