Redirect Query String issue with {Company Address (State / Province)} // (all others work)

Hello,

I can’t find this particular issue on here (apologies if I missed it).

For some reason my Redirect Query String for {Company Address (State / Province)} does not pass the data anymore. All the other Redirect Query Strings (e.g. Address Line, City, etc) still work just fine.

The Redirect Query String has worked until recently (haven’t updated to Gravity Forms 2.5 yet)…was wondering if there is a new format to query the state/province info when passing the field data?

Thank you!
-R

Hi Rufino. What does your query string look like currently, and where is the form located that is collecting that data to use in the query string?

Also, can you see if it is sending in the query, and it’s not being received on the other end, or is it not sending any data in the query string at all for that piece of the address?

Hello Chris!

Attached is the screenshot of the query string. All fields are getting passed except for “company_state={Company Address (State / Province): 19.4}”

Both forms are located in the same form list I am using. In this case, “Company Registration Form” is where I am gathering the Address field data and “Corporation Annual Meeting Minutes” is where the Address field data is being sent to (the appropriate parameters in the advanced tab are filled [there are no typos…keep in mind it worked until recently]).

As for seeing if the query is being sent, I am creating a document with GravityPDF and am able to see that all the fields (except for the State field) are being populated via the “Corporation Annual Meeting Minutes” form.

Is there another way to debug this to see what I may be missing?

Thank you!

Hi Rufino. To troubleshoot I would take these steps.

  1. Is the correct data stored in the entry for all those fields.

  2. Can you see in the URL when redirecting from form 1 to form 2, the data for all the parameters in the query string?

  3. Are all the fields populated correctly via the query string, in form 2?

Once you know which part is not working, you can figure out why.

Hello Chris - From what I see (URL, Entries, and even the Log files) everything is passing correctly.

I reached out to the Gravity PDF team with this. I also reviewed their logs and they show the Address>State field as empty. In addition, their logs do show a “gwro_hidden_capture” message for that field. Waiting for their response (they’ve always been pretty good with support).

Fun times indeed :grinning_face_with_smiling_eyes:

1 Like
© 2008 - 2019. Gravity Forms is a project by Rocketgenius Inc.