Recaptcha not working and purchased Licence saying invaled

Hello,

I’m trying to trouble shoot two issues ( one more pressing than the other). For some reason the re-captcha is not working on my install of Gravity forms 2.6.4.1

I copied the V2 keys directly from google for the clickable captcha, but yet it says the keys are incorrect.

The captcha field however does show and present the puzzle. But when clicking the correct tiles it will say the captcha is invalid. I’ve tried it on a PC, a mac, another persons computer, and my phone, the behavior is the same. I do not have any other captcha plugins installed.

I’ve also tried deleting the field and re adding it. Then I added the re-captcha to another form all together and still the same behavior.

you can see the form here http://tillescenter.org/contactus/

Second issue
I have a purchased license key, but yet my acct says I have none. Granted it may be old, but I did purchase it. Any record of what happened to it?

I recommend contacting us via a contact form with your license question, so we can figure that out first.