Problem within hidden fields being disabled and not enabling when shown

I’ve created a multi-page form with a bunch of conditional logic which results in fields being shown/hidden based on different selections. Up until sometime recently (I don’t know exactly when) it all worked fine, the form would load, hidden fields would be hidden until the logic to display them fired and then the user could interact with the shown field and make a choice (they’re primarily dropdowns).

Now, when the logic fires and a field is shown it is disabled and cannot be interacted with at all (in a few random cases the field won’t even show, but that’s not the main issue). The form can also receive data from other forms across the site and what I have noticed is that the field that is loaded first works fine, any other field that is shown (or replaces the original field) is disabled.

To my knowledge there has been no change to the plugin (it’s version, but I am wondering if it’s something to do with an update to WordPress as I think the site was originally built on 5.6.x and has since updated to 5.7.x. But for the time being I am stumped.

I’ve tried to look through other topics to see if similar issues have occurred and there are a couple of threads that look similar but don’t offer solutions, so I’m hoping this can be resolved. It’s also a client site so I don’t own/have the license, so this is my first port of call to see it is an issue that may have been resolved in a newer version or can be resolved somehow.

All help is appreciated and I’ll happily elaborate further and/or provide links if that helps.

Hi Stefan, that Gravity Forms version is pretty old and is not something we support. I recommend updating a staging site with a copy of your form to the latest Gravity Forms release, currently v 2.5.5, and checking there to see if the issue still exists. If it does, I recommend opening a support ticket here Support | Gravity Forms

The first step to obtaining support will be to update Gravity Forms to the latest and checking to see if the issue still exists in the latest Gravity Forms release. Thank you.

HI Chris,

Thanks, I’ve installed the latest version and the issue still occurs… although I have noticed a (possible) variation in the problem. I’m assuming opening a ticket will be the next step, however here’s some more information:

  1. Open the form, make a selection and the conditional fields works fine (no greying out etc)
  2. Browse to another page and then return to the form
  3. Make a selection and the conditional fields are now greyed out/broken
  4. Close browser window (seems to behave the same in normal or private browsing)
  5. Return to the site and go to the form, make a selection and all seems okay again

Additionally, if I enter the form via another form that is passing data across, it breaks immediately (by not showing the conditional field and/or by greying them out).



Hi Stefan. Yes, I recommend opening a support ticket for this issue:

Thank you.