How can you trigger Zapier with only a partial entry?

Hello Community,
I wanted to follow back up on an issue that you helped me solve in 2020. I need a partial entry to trigger zapier.

This last feedback helped me solve the issue but about a week ago it stopped working after an update.

I brought everything fully up to date it stopped working any idea what I do doing wrong?

Here is the code that was the solution before:

//Send new partial entries to Zapier.
add_action( 'gform_partialentries_post_entry_saved', 'send_to_zapier_on_partial_entry_saved', 10, 2 );
function send_to_zapier_on_partial_entry_saved( $partial_entry, $form ) {
    if ( class_exists( 'GFZapier' ) ) {
        GFZapier::send_form_data_to_zapier( $partial_entry, $form );

Hi Gera. There were changes in both the Gravity Forms Zapier Add-On and on the Zapier side with their updated app. I recommend opening a support ticket to get an idea of what needs to change in the code to make it work with the latest Zapier Add-On and Zapier app. Thank you.

Gera, we too are experiencing the problems you described. Is this happening after updating the Zapier Add-on to 4.0?

Yes, that is my guess.

Thank you for opening a support ticket.

Ok, I opened the ticket and he pretty much told me to do the same thing that you did. I only have a chance to work on this in the evening so a am just kind of frustrated I have to wait another night to try to solve this. Any idea what I could be doing wrong or what information I need to provide so that he can help me solve this issue.

add_action( 'gform_partialentries_post_entry_saved' , 'send_to_zapier_on_partial_entry_saved' , 10, 2 );

function send_to_zapier_on_partial_entry_saved( $partial_entry , $form ) {

if ( class_exists ( 'GFZapier' ) ) {

GFZapier::send_form_data_to_zapier( $partial_entry , $form );

} elseif ( function_exists( 'gf_zapier' ) ) {

gf_zapier()->maybe_process_feed( $partial_entry , $form );



If you haven’t edited the GF trigger in the Zap then you can roll back the Zapier Add-on to 3.3 to restore functionality.

If you HAVE edited the GF trigger in the Zap, then the GF trigger would have been automatically updated to 2.0 from 1.1.0 (Legacy - now deprecated in Zapier) and you are now stuck like we are until either Zapier restores 1.1.0 as an option (I have requested this - you should, too) or GF fixes Partial Entries/Zapier Add-on and/or updates the documentation for triggering the zap with a partial entry.

Man, that really sucks. Yes, I updated the Zap trigger a couple of days ago hoping that would fix it. Stephanie, I am seeing the issue before it even hit Zapier though.

Give this a watch:

Entries ‹ 57 — WordPress - Watch Video

I can provide logins if you want to take a look.

Please don’t share any logins on this public forum. Correspond directly if you would like to work on a site together. Thank you.

We are not seeing multiple entries like that.

Our form is not public and has Save and Continue enabled in addition to the Partial Entries (PE) Add-on. We are using PE to trigger submission of the form values to Zapier when a “Ready to Review” checkbox is checked by the user. This keeps the entry open for editing using Save and Continue instead of closing it as would happen with a normal submission button, which we have disabled.

Have you enabled logging for GF? If not, go to GF Settings > Logging and enable. This will give you more info on what is happening.

We have zeroed in on the Partial Entries Add-on - or more specifically the custom code that triggers the submission to Zapier - not working with Zapier Add-on 4.0. Here is the current code we are using:

add_action( ‘gform_partialentries_post_entry_saved’, ‘send_to_zapier_on_partial_entry_saved’, 10, 2 );
function send_to_zapier_on_partial_entry_saved( $partial_entry, $form ) {
if ( class_exists( ‘GFZapier’ ) ) {
GFZapier::send_form_data_to_zapier( $partial_entry, $form );
} elseif ( function_exists( ‘gf_zapier’ ) ) {
gf_zapier()->maybe_process_feed( $partial_entry, $form );

add_action( ‘gform_partialentries_post_entry_updated’, send_to_zapier_on_partial_entry_updated’, 10, 2 );
function send_to_zapier_on_partial_entry_updated( $partial_entry, $form ) {
if ( class_exists( ‘GFZapier’ ) ) {
GFZapier::send_form_data_to_zapier( $partial_entry, $form );
} elseif ( function_exists( ‘gf_zapier’ ) ) {
gf_zapier()->maybe_process_feed( $partial_entry, $form );

add_action( ‘gform_after_update_entry’, ‘send_to_zapier_on_update’, 10, 2 );
function send_to_zapier_on_update( $form, $entry_id ) {
$entry = GFAPI::get_entry( $entry_id );
if ( class_exists( ‘GFZapier’ ) ) {
GFZapier::send_form_data_to_zapier( $entry, $form );
} elseif ( function_exists( ‘gf_zapier’ ) ) {
gf_zapier()->maybe_process_feed( $entry, $form );

The only real difference between this code and the code we were running without issue with ZA 3.3 is the addition of the elseif and the entire 3rd function.

Additionally, the logs for PE when running ZA 4.0 will show this:

DEBUG → GF_Partial_Entries::maybe_save_partial_entry() Running.
DEBUG → GF_Partial_Entries::create_partial_entry() Aborting; Not enabled.

instead of something like this when running ZA 3.3:

DEBUG → GF_Partial_Entries::maybe_save_partial_entry() Running.
DEBUG → GFFeedAddOn::maybe_process_feed(): Checking for feeds to process for entry #5 for gravityformspartialentries.
DEBUG → GFFeedAddOn::maybe_process_feed(): No feeds to process for entry #5.
DEBUG → GF_Partial_Entries::maybe_save_partial_entry(): Updating existing partial entry. Success. Entry ID = 5.

Even though it says PE is not enabled, it is.

Really frustrating. We rolled back to 3.3, but two of our Zaps were auto-migrated to 2.0 so they no longer function with ZA 3.3 and never worked with ZA 4.0 + PE.

OK after doing some further testing I found that that multiple entries are happening when someone pushes the button again as it’s loading.

@Stephanie Have you tried testing this?

@chrishajer The guy on the support has not replied for 2 days. I feel like I am trying to figure this out on my own. Is there a way to make the button disappear or after I click it to disable it after one click?

This button would be the next page button on a multi-page form.

No, I have not tested it because we are not using any of the standard buttons to submit the form to prevent the entry from being marked completed and no longer editable by the submitter. As I stated, our entries are updated and submitted to Zapier when a checkbox is checked (this is where Partial Entries comes in).

As for your button issue, you should be able to use jquery to a) disable the button on click and b) conversely to re-enable the button on page refresh, etc.

HI @user5ed94fbaa1671914 - I did reply with a possible solution to prevent multiple submissions. I did not hear back from you after that. Please feel free to reply to that support ticket. Thank you.

Ok I think I am close.

Here is the code:
jQuery(function(){ (".gform_wrapper form").on(“submit”, function(e){
b = $(“input[type=button]”, this);
b.attr(“disabled”, true);
b.css(“background”, “darkgray”);
b.css(“color”, “black”);

I changed type=submit to type=button
What do I need to change this to? .on(“submit”, function(e){ ?
It’s not on submit it’s on the progress I guess because I am going to the next page. I am not sure whats that is called.

@chrishajer How can I get this figured out? it seems like changing this code to fit my use case should be simple. I tried a few things and can’t get it working. Can I hire someone on this form to get this working today? Can you suggest a fix?


Are your partial entries getting submitted to Zapier and actually triggering a Zap?

We are still unable to do so.

1 Like