What could be causing new form fills to not trigger Zap in Zapier?

The test run works fine in Zapier, it just conjures this “Bilbo Baggins” test lead out of nowhere, sends that to the CRM perfectly, says it works, but then never triggers at all despite a solid connection to Gravity Forms.

My suspicion is that this problem is because we have conditional questions in the form which are required, but aren’t shown to the user unless they meet specific conditions (obviously). So perhaps entries on this form are considered “partial entries” or something…?

We are getting form fills, but the Zap never runs despite the test working perfectly.

I don’t know what to do about that if it’s the problem, and nothing else tried so far has solved the problem – I’ve tried the following

*disconnected and reconnected GF
*created a new API key and consumer key/secret codes
*checking for error codes (none)
*checking the log to see if it’s triggering at all or if it’s the filter – it’s not triggering at all
*made sure we had the right form selected
*other stuff I’m forgetting already

ZERO form fills contain answers for all questions… because they are conditional. Do you think it could be the conditional questions that are the problem?

Are you using the Partial Entries Add-on?

If so, are you still using the form button option that is available in Form Settings > Form Button to submit to the form to the zap?

No, I’m not using the partial entries add on, it was a long time before I even considered it might be needed!

I’ll add it.

Yes, I am using the form button in form settings. I changed the text, but I did so within form settings.

If you don’t need the PE add-on then don’t use it. I asked if you were because since the Zapier Add-on was updated to 4.0 and the app trigger in Zapier was updated to 2.0, those of us that had been successfully submitting partial entries to a zap can no longer do so.

Conversely, using the standard submit button works fine in our testing.

Hey Stephanie,

After adding the partial entries add on I am not seeing a difference in terms of the triggering (or lack thereof) in the zap.

I enabled it for the relevant form — is there anything else I’d need to do if this is the solution?

Thanks so much!
Devin

Oh, ok.

I may disable it then, I guess. Never knew it existed, could be useful.

So are you saying you think the submit button not saying “submit” is the problem?

Tried changing it to “submit” and no change in terms of trigger

What you call the button is up to you and will have no affect on the functionality of the button. In the end it is still a submit button.

While troubleshooting our problems we tested a true submit button and it worked fine. Our problem lies with submitting partial entries to Zapier.

IIRC, I thought I saw a post where GF acknowledged a problem with the API for some users and were working on a fix. May want to search out that post.

A suggested solution in the docs–adding a filter in functions.php–worked for me.

© 2008 - 2019. Gravity Forms is a project by Rocketgenius Inc.