Gravity Forms Webhook incorrect JSON

I installed the latest Webhooks add-on today v1.5, running on latest WP: 5.9.2 and latest GF: and having this problem:

When I POST all my fields (screenshot of webhook config):

All of the posted fields are coming across in an array without the field names… screenshot:

It is so weird…

I have tried disabling ALL plugins except for GF (main) and the webhook add-on, still no dice.

Anyone seen this before?

The request body setting on the webhook feed configuration page must be set to the all fields choice so it’s sending the raw entry from the database.

You need to change it to the select fields choice and then use the settings that appear to define the api field names you need to use and the form fields you want to send for them.

Richard, thanks for the reply.

Are you saying this is the expected behavior?

BTW, here is my data that is being posted using

I just installed the very latest GF version today v

When I choose the “Select Fields” radio button, it doesn’t show me any other settings… I think I had seen that before where it gives me a list of the fields or something… but it doesn’t seem like that would affect how they are labeled in the json, right?

I started over with a brand new simple form and got the same results:

It seems that the GF built in fields are being passed correctly as name/value pairs, but my fields are just labeled “1”, “3” and “5”…

Can you try testing from your side to see if yours do this also?

Hi Patrick. I took an existing form, and sent All Fields to the and I can see that all the keys are numeric:

  "2": "",
  "3": "All Field Services",
  "4": "Boss",
  "6": "(708) 666-8888",
  "7": "125",
  "8": "623b9920ea3ae5.09794534.png",
  "id": "62391",
  "form_id": "252",
  "post_id": null,
  "date_created": "2022-03-23 22:03:12",
  "date_updated": "2022-03-23 22:03:12",
  "is_starred": "0",
  "is_read": "0",
  "ip": "",
  "source_url": "",
  "user_agent": "Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:98.0) Gecko/20100101 Firefox/98.0",
  "currency": "USD",
  "payment_status": null,
  "payment_date": null,
  "payment_amount": null,
  "payment_method": null,
  "transaction_id": null,
  "is_fulfilled": null,
  "created_by": "1",
  "transaction_type": null,
  "status": "active",
  "1.3": "Chris",
  "1.6": "Hajer",
  "5.1": "1234 Maple Ave",
  "5.3": "Chicago",
  "5.4": "Illinois",
  "5.5": "60606",
  "5.6": "United States",
  "1.2": "",
  "1.4": "",
  "1.8": "",
  "5.2": ""

Then I switched from all fields to “Select Fields”. My configuration looked like this: firefox IalukIEpgW.png - Droplr

And this is what arrived at the

  "full_name": "Mister Single",
  "first_name": "Mister",
  "last_name": "Single",
  "email_address": "",
  "company_name": "Single Field Services"

This is with Webhooks 1.5 and Gravity Forms

Great! That at least tells me how it is supposed to work… now to figure out why my Select Fields isn’t working… any ideas on that?

Can you explain what you mean or show an example of what is happening?

Ok, I figured out that a plugin called “Content Holders” was preventing the “Select Fields” from working properly.

I’ll find a workaround, thanks.