Gravity Forms 2.4 Update Causes Error Upon Submission - WPENGINE SSLed Websites

I am doing my regular plugin updates for gravity forms. I have websites hosted on Godaddy and Wpengine. All of my wpengine websites (except the one currently in build process) all have SSL certificates. My Godaddy sites do not yet.

All of my godaddy sites updated without issue. I updated my wpengine site with out the SSL and tested the form, it worked fine as well. But to my surprise all 4 of my wpengine sites that have SSLs on them each game the following error when I attempted to test my forms after updating:

An error prevented the entry for this form submission being saved. Please contact support.

I do not know if this is a gravity forms issue or wpengine issue. I reverted my forms to 2.3.6 and they are back in working order.

Has anyone else had this issue?

Despite already having tested reverted and reupdating. I tried it again, and it seems to have fixed itself. Maybe it was just an interrupted update - twice?

Oh well. Ignore this. Thanks

Users are reporting the same error across multiple website, hosted on multiple servers.
It does appear to be fixing itself. The sites that had issues no longer do.

I noticed that downloading the plugin directly from GF, is version 2.4.0.1, whereas in my wordpress sites that are automatically updated, its version 2.4. Any idea if this minor update is related?

Thanks!

I recommend opening a support ticket if you need assistance with the error on SSL sites still. Thank you.

https://www.gravityforms.com/open-support-ticket/

Yes same issue here across 50+ client sites this morning. Had one client launch a campaign this morning and all submissions were throwing the error! Big issue. I found out that manually going in setting and clicking “save” seems to fix it. There goes my Friday! :grinning:

This can happen if Gravity Forms is updated with a management tool like ManageWP. The database upgrade on single sites (not multisite installations) does not run until the admin loads. You can update the database and clear the error by loading any page in the wp-admin WordPress dashboard.

We are working on a fix for this issue and will share it as soon as it’s available.

Thanks, yeah its a major issue as I have 70+ sites under ManageWp as do countless others id imagine!

Thanks for the instructions. That makes sense.

Hi Chris,
Does every site that uses gravity forms, that was updated via an update manager, to 2.4, need to be visited (logged-in via wp-admin)?

At this time, that will fix the issue. However we are still working on a solution to the issue. That is only a workaround that we know will work.

Hi Chris, I just started having the same issue and don’t know how to revert to an older version of gravity forms. Do I export my forms, delete the plugin, re-install and then import my forms?

We don’t recommend reverting to an older version. If you need support, I recommend opening a support ticket here https://www.gravityforms.com/open-support-ticket/

1 Like

I am having the error on submission issue on two sites. Is the fix as simple as removing 2.4.11.x to 2.4.11.6 (most recent version)? Thank you in advance.

That’s standard practice for Gravity Forms: they release very minor updates all the time, then they distribute the updates on a regular basis. You can log into your account at any time and get access to the very latest version.

1 Like
© 2008 - 2019. Gravity Forms is a project by Rocketgenius Inc.