GF is broken

I have a website with wordpress 5.7.2 and GF
I have download and put the latest version of GF, and there are some JS errors.
I can’t use the builder, he is completly broken.
The errors :

10:14 AM

Uncaught TypeError: gform.applyFilters is not a function
Uncaught TypeError: gform.addAction is not a function
Uncaught TypeError: gform.initializeOnLoaded is not a function
Uncaught TypeError: gform.initializeOnLoaded is not a function

Anybody have an idea of what’s the problem ?

Thank’s to all !

Hello. We do not have widespread reports of any issues with Gravity Forms v2.5.7.5. I suspect the issue on your site is either:

  1. caching. Please try logging out and logging in with a new browser, and clearing any server side caching or plugin cache.

  2. conflict. You may have a conflict with custom code you are using or another plugin or your theme on the site. You can use either of these methods to check for conflicts:
    b. Testing for a Theme/Plugin Conflict using the Health Check & Troubleshooting Plugin - Gravity Forms Documentation

If you are not able to make things work, please open a support ticket:

Thank you.

1 Like


GF version probably is the same as v2.5.8. I got the exact JS issue in the console. There is no plugin conflict or theme conflict on my site. Somehow, JS is not working both in the backend admin and the rendered form in the website.

I am the administrator role, I can’t edit the field from those React-based components in the form editor.

Visitors on the website, click on the drop multi-files, and nothing happens. I check the console, there is a bunch of JS issue mentioned above from @webcd.

Temporary resolution: I rolled back to version 2.5.7. And everything is working fine. No more JS issue in the console.

Where do I go to download the previous version? I want to try the same resolution you tried.


Hi Jesse, I have a version control system, and rolled back to previous version from my internal development tool. I couldn’t find any download link on Gravity Forms website for a particular requested version. They always release the latest one on the download button in the My Account profile if you look at the hyperlink, the downloadable file is stored at AmazonAWS S3 with access token only.

You might want to contact support team and ask them for version 2.5.7. I can’t publish a download link of licensed product.

1 Like

Thanks, I’ll reach out!

I have the excact same problem as stated above. Even with GF v2.5.8 :pensive:
I downgraded the Plugin as suggested by Linh Pham and with an older Version it works. So I think, yes there is an issue!

Hopefully there’s a fix soon.

1 Like

We had a similar issue - lots of JS errors, “… is not a function” leading to display:none on form.
We were on version 2.5.8 and found that reverting to 2.5.6 did fix the issue.
However, we eventually discovered that we had previously added some custom code to move GF scripts around that we found here:

Removing the following hooks fixed the issue:
add_filter( 'gform_cdata_open', ...
add_filter( 'gform_cdata_close', ...
We kept the following line:
add_filter('gform_init_scripts_footer', '__return_true');
So it seems the advice in the above post is breaking something in recent releases of GF.
Hope that helps someone.


Thanks so much! Sure enough, we had these filters in place. I worked around them and this fixed it. :tada:


This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.