2.6.1 - Cannot edit forms anymore

I get the following error in my browser console when I load the admin form editor:

Uncaught TypeError: gform.initializeOnLoaded is not a function

This seems to be the root problem of a bunch of following problems that makes the editor useless.

I have tried the following:

  1. Disable all other plugins other than Gravity Forms.
  2. Change theme.
  3. Turning on “No Conflict Mode” in Gravity Forms.

Nothing works.

Any help is appreciated.

1 Like

Hello,

Could you try forcing the scripts to output on the page by returning true for the filter gform_force_hooks_js_output:

add_filter( 'gform_force_hooks_js_output', '__return_true' );

Thanks Paul - was having a similar issue today after the recent updates I assume when using Beaver Builder / PowerPack Addon / Gravity Form Module and the “Widget” - happy to provide more info if it will help

The code snippet doesn’t do anything. I added it to a custom plugin as well as the theme’s functions.php file.

The error even persists on a fresh server, default settings, with Gravity Forms 2.6.1 newly installed.

Hello Itek. We don’t have any other reports of this issue happening. I recommend opening a support ticket for this:

https://www.gravityforms.com/open-support-ticket/technical/

The first step in troubleshooting will be the conflict test, which you have already performed. Be sure to mention that in your ticket so we know that is already done. Thank you.

@user5ba252a56c7565.7 or @chrishajer were you able to figure it out?

I’m running into the same problem. I tried adding the gform_force_hooks_js_output line to functions.php but that didn’t seem to change anything.

The existing forms work on the live website, but the form editor won’t let me add/edit/remove form fields, and I get the same gform.initializeOnLoaded is not a function error in the console on the form editor page (and any Forms-related page, including viewing all forms and editing a Page or Post).

When using the form editor page, I also get gform.addAction is not a function and gform.addFilter is not a function.

I’m happy to submit a ticket as well, but it seems I’m not the only one with the issue.

Same issues here after update. Seems to be a major issue, reverting back to an earlier version to get things working again.

For anyone having this issue, I recommend opening a support ticket so the issue can be investigated. Thank you.

https://www.gravityforms.com/open-support-ticket/technical/

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.