Fatal error after latest update 2.4.18 | 2020-05-06

Debug log says:

[07-May-2020 08:31:28 UTC] PHP Fatal error: Cannot declare class GF_Field_Address, because the name is already in use in /Users/s****/Desktop/my_sites/****-final/app/public/wp-content/plugins/gravityforms/includes/fields/class-gf-field-address.php on line 0

The zip only contains one instance of that field type, it’s possible WordPress experienced an issue during the update and copied the file twice. Try reinstalling using a fresh zip from the support site: https://www.gravityforms.com/my-account/downloads/

Had the same exact same error when the update was released. At the time support noted it hadn’t been reported yet but appears others are experiencing as well. I also installed via the standard WordPress update feature which appears also caused it to duplicate a file and cause the error. As the other person noted, downloading the zip directly from Gravity forms resolves the issue.

Thank you for sharing your experience.

© 2008 - 2019. Gravity Forms is a project by Rocketgenius Inc.