Can't Create a New Form

Updated Gravity Forms to 2.7.2 and now when I click Create Form, a pop up appears with all the templates, but the pop up is not scrollable, and does not fit inside my browser window so that I can even see all the choices. Selected one and clicked Use Template and the pop up window refreshes with something at the top that is cut off, but there’s a second Use Template button and when I click it, nothing happens. I use Gravity Form in every site I design and I’ve never had this happen. I can’t create a form. I’ve tried in Google Chrome and Safari and the same thing happens in both. Any help is appreciated.

I have the exact same problem. Just updated to 2.7.2.

Same here. I suspect that the devs already know about this major issue, as I went to another site I’m developing to see if I had the same problem there. That site is running GF and it is not showing the option to update to 2.7.2. I’m guessing (hoping?) they’ve already rolled back the stable version while they’re working on a fix.

We just released a fix for this today in version! You can get this version from the downloads page on, and it will go out in an automatic update next week in version 2.7.3.

Great news, thanks for resolving that so quickly.

It’s not appearing in my account - I still just see

Morgan, I went to my account and downloaded the Gravity Forms download that was available. I installed it via FTP and I’m still seeing the problem and my version number hasn’t changed. Is there a special link within my account to receive the version with the fix? Thank you!

I can confirm this is fixed for me in I did not see that version coming up in the updater, but I was able to download it from my account here and install it over the 2.7.2 version I had on my site. Thanks for fixing the issue quickly.

I downloaded the link in my GF account and the zip file is named So I don’t think I have the correct version and the issue is still happening.

Same problem on several of my sites

Hi, bethalex. You can disable “No Conflict” mode on the Forms → Settings page and clear your cache, and the form template library will be usable. Or you can install, available on your downloads page, which will also take care of the issue without having to change “No Conflict” mode.

If these suggestions do not work, please open a support ticket here:

Thank you.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.