500 post error after trying to send a form [RESOLVED]

Hi!

I’ve submitted a ticket last week for this issue but I didn’t get a response yet so we will try it over here.

Whenever I try to submit a GF form, I’m getting a 500 post error in console log and when I check WP debug.log, I see this:

[16-Oct-2020 11:23:30 UTC] WordPress database error Duplicate entry '0' for key 'PRIMARY' for query INSERT INTO wp_gf_entry (form_id, ip, source_url, date_created, date_updated, user_agent, currency, created_by ) VALUES (2, '163.158.197.98', 'https://private/company/contact/', '2020-10-16 11:23:31', '2020-10-16 11:23:31', 'Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_5) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/private Safari/537.36', 'EUR', '3') made by require('wp-blog-header.php'), wp, WP->main, do_action_ref_array('wp'), WP_Hook->do_action, WP_Hook->apply_filters, GFForms::maybe_process_form, GFFormDisplay::process_form, GFFormDisplay::handle_submission, GFFormsModel::save_lead, GFFormsModel::save_entry

Could someone help us out please?

Thanks in advance!

Hi Justin. We did reply to your ticket on Oct 16 and it shows that your email client received the message. This is what Samuel sent to you:

That error is from your MySQL server and suggests an issue in the database with the AUTO_INCREMENT setting in the evo_gf_entry table, for some reason that setting was lost. That is not something Gravity Forms has any control over but something related to your database server. To fix that you can try to enable AUTO_INCREMENT in this table again following the steps below.

IMPORTANT : Before proceeding with this be sure to make a full backup of your database (just in case).

  1. Open phpmyadmin from your hosting panel, go to your WordPress database and find the table mentioned above at the left of the phpmyadmin screen, click on it.

  2. Now click on Structure tab (at the top).

  3. Make sure that AUTO_INCREMENT is shown in the Extra column for the id row, click Change and enable it by checking the A_I checkbox and clicking the Save button.

If there are many rows using the same id shown on the error message, you would need to delete the duplicates before completing the above steps.

Now try again to replicate the issue, it should work now or add new error messages.

If you don’t feel comfortable enough using phpmyadmin to perform these actions please contact with your hosting support for further assistance to perform the above steps.

Regards,

2 Likes

Thank you! It has been fixed now.

1 Like

Thank you for the update Justin.