WP Super Cache + Gravity Forms issues [RESOLVED]

We seem to continue encountering issues with WP Super Cache and Gravity Forms. I am running Fresh Forms as well. At any rate, lately if Super Cache is enabled each form on submission will redirect to the front page on reload.

I’m not sure how to troubleshoot this, I don’t see obvious console or network errors. The logs look like this while I was testing:

021-12-17 18:35:25.428435 - DEBUG → GFFormDisplay::process_form(): Starting to process form (#9) submission.
2021-12-17 18:35:25.429626 - DEBUG → GFFormDisplay::process_form(): Source page number: 1. Target page number: 0.
2021-12-17 18:35:25.431085 - DEBUG → GFFormDisplay::process_form(): After validation. Is submission valid? No.
2021-12-17 18:40:02.998972 - DEBUG → GFFormDisplay::process_form(): Starting to process form (#9) submission.
2021-12-17 18:40:03.000318 - DEBUG → GFFormDisplay::process_form(): Source page number: 1. Target page number: 0.
2021-12-17 18:40:03.001946 - DEBUG → GFFormDisplay::process_form(): After validation. Is submission valid? No.
2021-12-17 18:41:35.465297 - DEBUG → GFFormDisplay::process_form(): Starting to process form (#9) submission.
2021-12-17 18:41:35.466556 - DEBUG → GFFormDisplay::process_form(): Source page number: 1. Target page number: 0.
2021-12-17 18:41:35.467957 - DEBUG → GFFormDisplay::process_form(): After validation. Is submission valid? No.
2021-12-17 18:45:56.328506 - DEBUG → GFFormDisplay::process_form(): Starting to process form (#9) submission.
2021-12-17 18:45:56.329636 - DEBUG → GFFormDisplay::process_form(): Source page number: 1. Target page number: 0.
2021-12-17 18:45:56.331183 - DEBUG → GFFormDisplay::process_form(): After validation. Is submission valid? No.
2021-12-17 18:47:04.084707 - DEBUG → GFFormDisplay::process_form(): Starting to process form (#9) submission.
2021-12-17 18:47:04.085921 - DEBUG → GFFormDisplay::process_form(): Source page number: 1. Target page number: 0.

Appreciate any insight, thanks!

Those log results may be when I had Super cache disabled and I was submitting blank forms, just FYI.

You’re getting the above for each time you try to submit the form, which means your form is failing validation. You can add the following your theme’s functions.php file: Custom Logging Statements - Gravity Forms Documentation

That will add more information about what’s causing the validation issue.

1 Like

And do you have any log of a submission done with the caching plugin enabled and filling all the form required fields?

If you’re using any of the Fresh Forms supported embedding methods the page shouldn’t be cached anyway.

Thanks for the responses and the Fresh Forms plugin, Samuel!

Ultimately I think this came down to a conflict with Super Cache + Cloudflare.

Stopped using Super Cache and added page rules to cloudflare to prevent caching on their end, we seem to be back to operational.

I do have those log entries for successful submits, thanks for the custom logging statement suggestion as well. I’ll revisit this if the issue occurs again. Thanks!