Unable to Authorize Card - No Response from Stripe.js

Hi all,

I’m having a strange problem with Gravity Forms Stripe integration. Everything works correct in Test Mode, but when I move to Live Mode I get the No Response from Stripe.js error for every transaction. I don’t know why Test Mode is different from Live Mode.

So far I have tried rolling the keys and starting a new Webhooks integration. I am seeing a couple of things that tell me that it’s a Webhooks error. The first is that it looks like there’s logs on the Stripe dashboard for the purchase, but it stops there and does not go back to the website. It will work one time and then it won’t work at all. I am not sure what would cause that, but that’s all I can figure out at this point.

Any advice would be appreciated. Thanks!

I recommend opening a support ticket for this issue. We’ll need more information that we can gather in these community forums.

Open a support ticket here:
https://www.gravityforms.com/open-support-ticket/

I have one that hasn’t been answered and probably won’t be answered today since it’s almost closing time; my request was to see if anyone has encountered similar issues.

That’s the best place for your issue. I’ll leave this open in case someone else has a solution to share.

I’m getting a new error: “You cannot use a Stripe token more than once” So I’m not sure what could cause that.

For anyone else having similar problems there was a conflict with the plugin Invisible Recaptcha. Removing it solved my issue. Thanks!

2 Likes

Invisible CAPTCHA is built in to Gravity Forms now, so you would not see a separate plugin for that anyway. Thanks for the update.

Well just to clarify yours uses V2 and this plugin uses V3. V3 would be my preference as it’s a little more human-friendly but I am fine switching to V2 for these forms.

Thanks!

Thanks for the info. We have plans for reCAPTCHA v3, but it is not implemented yet. There are some data handling concerns (with everything being sent to Google for review/verification.)