Recaptcha not catching spammers

My clients are getting lots of spam. The recaptcha is installed and appears to be working fine because if I don’t check it, I can’t submit the form. I’ve attached a picture. Have spammers figured out a way to check the box or what? How can I keep the spammers out? It’s the free phone consultation form down below here https://elialaw.com/

The spammers have gotten very smart and in a lot of cases are no longer bots, but are people instead. Have a look at this article for some tips on preventing spam submissions in your forms:

I’ll leave this open in case anyone has any other experience to share.

I’m having the same problem with all of my clients sites. I install GF, enable honeypot, and enable recaptcha, and almost immediately they start getting spam. Sometimes the volume of spam is ridiculously high. I’ve used other form options (and currently use other form options in some settings), and none of them produce as much spam as the GF forms.

There’s gotta be a reason for this or something that can be built into GF to help, right? It’s frustrating for me and for my clients.

Open to suggestions!

This is a bit of work, but if there are repeat offenders submitting spam, you can use the form’s conditional logic settings to hide the Submit button if the message field, or any other field contains urls, phrases or other content that identifies it as spam.

I’d suggest installing the Gravity Forms Zero Spam for the GravityView team (they recently took over the plugin).

It’s free on the WP repo, I’ve installed it on a few sites and it took out all their Spam! No configuration!

Highly recommend this plugin on all sites with GF installed!

Ken

3 Likes

Best solution I’ve implemented is if your site is on cloudflare then enable a challenge for the page the form is embedded on.

You should also double check to make sure the anti-spam honeypot option is enabled. I do believe that with one of the recent updates this option was untoggled even if you had previously enabled it.

Update: I have a client who insists on using his AOL email address to send and receive. AOL stopped accepting any form submissions, so I installed WPForms to see if that worked. I didn’t. I didn’t notice that the spam also stopped. A week later I put back Gravity Forms after I talked him into getting a professional email address on his domain. Immediately he got bombarded with spam again. Same site. Both forms had recaptcha. The WPForms form did not attract spammers. Gravity did. I have another client with a Gravity form that I forgot to add recaptcha to and there is no spam there. So something about GF + recaptcha is the problem, it appears. Spammers must be looking for that.

Quick reminder that the official Gravity Forms support of Akismet and reCAPTCHA functionality have been added to separate add-ons recently. It does not affect your existing versions if you were running them with existing Gravity Forms core, but reCAPTCHA Add-On does add version 3 CAPTCHA support.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

© 2008 - 2021. Gravity Forms is a project by Rocketgenius Inc.