GravityForms slowing down my backend

I have this website where we use GF (Version Since a while it was very slow in the backend (par example going to Posts>AllPosts is taking +1 minute to load, also showing all plugins is taking 90 seconds to load).

  • I disabled alle plugins, it was fast again
  • I started up all plugins, except GF, its ok

As soon as i startup GF it slows down.

  • I deleted all entries from the form (we only have 1 forms) : did not help
  • deactivated the form : did not help
  • checked system-report in GF, 1 error: cURL error 28: Operation timed out after 2000 milliseconds with 0 bytes received (Host (Siteground) Support sais that is not in their system being caused).

So… i get stuck here. Only thing left i can imagene is delete the plugin and form and re-install… but in the GF forum i noticed support helping people out on this kind of stuff.

So… can you help (plse)?


Hi Ralph,

I can’t replicate the issue in a default WordPress installation. You will want to try the following remaining tests:

  • Switch to a default WordPress theme (e.g. Twenty Twenty-One).
  • Disable all plugins and enable only Gravity Forms.

Regarding to the cURL error 28, that’s for the Background Tasks, right? If so, that has no relation with the slowness and certainly it’s a problem that your host support should resolve.

To be clear, we don’t use cURL directly, we use the WP core function wp_remote_post().

This is exactly the code used:

		$query_args = array(
			'action' => 'gf_check_background_tasks',
			'nonce'  => wp_create_nonce( 'gf_check_background_tasks' ),

		$url = add_query_arg( $query_args, admin_url( 'admin-ajax.php' ) );

		$response = wp_remote_post( $url, $args );

Basically what it does is to ask WP for the URL of your site and use wp_remote_post() to connect to admin-ajax.php file, then WordPress uses cURL to perform the request. The full URL use for the request would be something like ( would be your site domain).

So in short when you see that cURL error 28 for Background Tasks, your server is not responding to itself.

You can find some details about this error and tips that could help in the following article: cURL error 28 in WordPress – Samuel Aguilera
But most of the time this is something that will require the assistance of your host support.​

1 Like

Hi Samuel,

I …
• Switch to a default WordPress theme (e.g. Twenty Twenty-One).
• Disable all plugins and enable only Gravity Forms.
All was fast.

Than i enabled everything back … and all remained fast.

Im really clueless but it helped in some way.

Even my cURL error is gone.

Clueless but ok…



This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.