GF Advanced Permissions missing for custom user role


I’m using GF with Advanced Permissions and would like to give access to the permissions setting to a custom user role I create with User Role Editor.

If I make a copy of the administrator user role with all gravity forms permission and set that role to a user the “permissions” setting on a form is missing. It seems like only the existing administrator role can access the permission settings.

Is there a way how I can give a user access to the permissions without making them a site administrator?

You can give a custom user role access to the Gravity Forms permissions settings without making them a site administrator. To do this, you’ll need to ensure your custom user role has the required Gravity Forms capabilities.

Here’s a step-by-step guide on how to do this using the User Role Editor plugin:

  1. Install and activate the User Role Editor plugin if you haven’t already done so.

  2. In your WordPress dashboard, navigate to Users > User Role Editor.

  3. Click the ‘Add Role’ button to create a new user role. Give it a name and display name, then click ‘Add Role’.

  4. Select your newly created role in the “Select Role and change its capabilities” dropdown.

  5. Scroll down the list of capabilities and make sure your custom user role has the following Gravity Forms capabilities:

  • gravityforms_view_settings
  • gravityforms_edit_settings
  • gravityforms_uninstall
  • gravityforms_view_entries
  • gravityforms_edit_entries
  • gravityforms_delete_entries
  • gravityforms_view_entry_notes
  • gravityforms_edit_entry_notes
  • gravityforms_delete_entry_notes
  • gravityforms_export_entries
  • gravityforms_view_forms
  • gravityforms_edit_forms
  • gravityforms_delete_forms
  • gravityforms_preview_forms
  • gravityforms_duplicate_forms
  • gravityforms_create_form
  1. Click ‘Update’ to save the changes.

  2. Now, assign the custom user role to the user you want to grant access to the permissions settings.

  3. The user with the custom role should now be able to access the permissions settings for Gravity Forms.

Hello Faisal and thank you for your reply. That is exactly what I’m doing but the permissions setting is still missing in Gravity Forms. Every other function seems to work. Here are my settings and the Permissions button is still missing. If I change the role to Administrator the permission button is there but never with any other role.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.