Dynamic population only working while logged in (part 2)

Looking at this forum topic, it doesn’t really go anywhere or provide any really worthwhile solutions.

I do have caching enabled for the site, I mean … it’s required for increasing my page load speed.
That being said, why wouldn’t the script work around the caching considering what the feature inherently should do in the first place?

I don’t see any conflicts with the theme or other plugins either.
Please advise.

Mike,

I found that you created this forum topic after replying to your ticket a few hours ago. This forum is not an official support channel, so tickets get more priority. For this reason for license holders it’s recommended to create a ticket rather than posting here, you don’t need to do both. If you have any further comments about this, I would recommend you to reply to the ticket response, as you would get faster assistance.

In any case, I’m leaving here the ticket reply I sent you just for the record, as I think it could help other people also.

Caching is not for everything, if you want to dynamically populate values in your form, you need to exclude the URL where your form is embedded from cache. This is enough in most cases, but your host is also known to cache query string parameters: utm and gclid Variables and Caching | WP Engine®

So when dynamic population is done by a query string, you need also to ask your host to exclude the parameters you want to use from their cache.

To be clear, serving a cached page means PHP is not running for the page load, you’re serving a static HTML copy of the page. This is intended for pages where you don’t make changes frequently and where you don’t need dynamic data.

The dynamic population feature uses PHP to get the value and populate the form field(s). Therefore excluding the page where you embed your form from cache is the only way to allow the dynamic population feature to work.

Your host cache is disabled logged in users, for that reason it works when you’re logged in.

1 Like