Custom user meta not showing - Android / iOS mobile (not via dev tools)

Hi,

I have added a custom meta text field using ACF to each Wordpress user called “van_reg” and populated it for each user.

I’m pulling this meta value through to a gravity form / single line text field as a default value that can be over written - {user:van_reg}

When viewing the form on a browser on a PC the {user:van_reg} field populates in the form as you would expect.

When viewing the form on a browser on a mobile device (iPhone + Android) the {user:van_reg} field in the form does not populate with anything at all and is blank. NOTE: this is on an actual device and not via dev tools (where is shows).

Another gravity form / single line text field on the same form using {user:first_name} {user:last_name} does populate on both mobile and PC.

I’m not sure why one meta’s {user:first_name} {user:last_name} works but custom meta {user:van_reg} does not?

I am able to pull the custom meta field through in the actual page itself where the form is shown via a gravity shortcode, it’s just in the form field itself it does not show.

Any ideas?

Thanks!

Do you have a URL where we could view this form? And just to confirm, are you logged-in on both the PC and phone?

Hi - yes logged i via the phone - you have to be logged in to view the site as it’s used for our engineering team.

It’s tricky to give you a public URL but in terms of replicating, the ACF is basic text field as per below;

and the gravity form is puling user meta through as per below:

The form field shows the value on a PC on an actual phone tested (iOS and Android) the field is blank??

Location settings for the ACF is:

I tried a similar setup (based on your screenshots) and its loading for me on every device I tried. This makes me think there might be a plugin conflict. Are you seeing the same issue with just Gravity Forms and ACF active? Also, does the value get populated if you view the form in preview on the mobile device?

Yeah it’s odd… the ACF field populates in the page text above form shortcode… so the value is getting pulled through… it’s just not showing in the actual gravity form text field.

It’s shows on PC but not on the actual device itself when viewing the form.

I’ll try and clone the site and send you login details so you can see.

What’s weird is that {user:first_name} {user:last_name} does pull though and show in the gravity form - but this is a standard meta field not one setup by ACF.