Critical Error - Erroneous data format for unserializing [RESOLVED]

https://gilkey.pixaura.com/wp-admin/

//entire errror

Warning: Erroneous data format for unserializing 'Gravity_Forms\Gravity_Forms\License\GF_License_API_Response' in /home/customer/www/gilkey.pixaura.com/public_html/wp-content/plugins/gravityforms/includes/license/class-gf-license-api-connector.php on line 97

Fatal error: Uncaught Error: Call to a member function can_be_used() on bool in /home/customer/www/gilkey.pixaura.com/public_html/wp-content/plugins/gravityforms/common.php:2813 Stack trace: #0 /home/customer/www/gilkey.pixaura.com/public_html/wp-content/plugins/gravityforms/common.php(2981): GFCommon::get_version_info(true) #1 /home/customer/www/gilkey.pixaura.com/public_html/wp-content/plugins/gravityforms/gravityforms.php(916): GFCommon::check_update(Object(stdClass), true) #2 /home/customer/www/gilkey.pixaura.com/public_html/wp-includes/class-wp-hook.php(309): GFForms::check_update(Object(stdClass)) #3 /home/customer/www/gilkey.pixaura.com/public_html/wp-includes/plugin.php(189): WP_Hook->apply_filters(Object(stdClass), Array) #4 /home/customer/www/gilkey.pixaura.com/public_html/wp-includes/option.php(1957): apply_filters('site_transient_...', Object(stdClass), 'update_plugins') #5 /home/customer/www/gilkey.pixaura.com/public_html/wp-includes/update.php(780): get_site_transient('update_plugins') #6 /home/customer/www/ in /home/customer/www/gilkey.pixaura.com/public_html/wp-content/plugins/gravityforms/common.php on line 2813
There has been a critical error on this website. Please check your site admin email inbox for instructions.

Learn more about troubleshooting WordPress.

Hi James. The product team is aware of the issue and is working on a fix. In the meantime, try this:

  1. Open your site wp-config.php file using an FTP client.
  2. Add the following line to the file:
    define( 'GF_CACHE_DEBUG', true );
  3. Now go to Forms → Settings page – which should now load without issues.
  4. Click the Save Settings button.

If that worked, you can go back to the wp-config.php file and remove the GF_CACHE_DEBUG line. If you have any other questions, please let us know.

Thanks Chris,

I was able to get the site back up and running using this ‘fix’, but when I remove the GF_CACHE_DEBUG line the issue returns.

Cheers.

Chris,

Same issue here with a number of sites. Can you share more information please? It seems to random. We manage about 50 sites, it is affecting @ 10 so far.

Thank you

If you open a support ticket we can send you a build which contains a hot fix for this issue:

https://www.gravityforms.com/open-support-ticket/technical/

Is there a place we can download the hotfix ? will this be resolved in the next release ? If so when is that ?

2 Likes

The hotfix is only available by contacting support at this time. This issue will be resolved in the next release, but we do not have a date for the release. If you have any other questions about the issue or the hotfix, I recommend opening a support ticket. Thank you.

This basically took out my entire website. The GF_CACHE_DEBUG hack worked, but sure seems like it warranted a hot fix.

Please post hotfix PUBLICLY - I am a licensed user but this is NOT COOL.

3 Likes

Wow that was fun. Does gravityforms_2.6.2 include the hotfix? Can we not share that here please?

Gravity Forms 2.6.3 was released a couple of hours ago which contains a fix for this issue. It’s available from your downloads page:

https://www.gravityforms.com/my-account/downloads/

2 Likes