Confirmation is not working

In each form I set confirmation as I wish, but showed confirmation is always the one which is configured directly in code (in .php file) and not this one which is configured in form settings.

If you’re getting a default “Thank you” message instead of the content you have customized for the Default Confirmation, that could indicate your submission is being flagged as spam by Akismet or any other anti-spam solution enabled for your form.

If you have an anti-spam solution enabled for the form, try disabling it. If this doesn’t help, you will want to open a support ticket for further investigation of the issue.

Thank you for your reply.

I deactivated all anti-spam solutions but it is still not working …

Unfortunately admin of my webpage have license and I don’t have it, so I can’t access to opening support ticket … :frowning:

I have the same issue. We do not use Akismet in our web solution and yet we have this problem. I created an example where there is a single radio button field with Yes and No as the two options, and two conditional confirmation messages have been added. Whichever option is chosen, the user is sent to neither of the correct confirmation message but instead to the Default which is not helpful.

Is this a known bug?
Thank you

Hi dannyb. I recommend opening a support ticket and including your form export and system status report:

https://www.gravityforms.com/open-support-ticket/technical/

Thank you.