Chained Select Addon Skipping Data in CSV file During Upload

Gravity Chained select addon does not seem to be able to upload large data from CSV even after using the filter (https://docs.gravityforms.com/gform_chainedselects_column_unique_values_limit/). When you upload a csv file, some data are omitted. What could be the problem?

Hi Adeyemi. I recommend opening a support ticket, and sharing the CSV with us (by hosting it at a filesharing site and including a link to the file) so we can take a look:

https://www.gravityforms.com/open-support-ticket/technical/

Thank you.

Hi @ade.ogunade

The Gravity Forms Chained Selects Addon allows you to create chained selects within your Gravity Form, where the options in one select field depend on the selected option in another. One possible issue you may be experiencing is that the Chained Selects Addon has a limit on the number of unique values that can be displayed in a column. If your CSV file contains many unique values in a column, some of the data may be omitted when you upload the file.

To fix this issue, you can try using the gform_chainedselects_column_unique_values_limit filter to increase the limit on the number of unique values displayed in a column. Here is an example of how you can use this filter:

add_filter( 'gform_chainedselects_column_unique_values_limit', 'set_chainedselects_column_unique_values_limit' );

function set_chainedselects_column_unique_values_limit( $limit ) {
   return 1000;
}

This code will increase the limit on the number of unique values displayed in a column to 1000. You can adjust this value as needed to meet your specific requirements.

I hope this helps! Let me know if you have any other questions.