shows error, highlights CC area in red as if there was an error but still processes the payment

Out of nowhere our form stopped working to process payments using the add-on. When the user clicks submit the page reloads with the error “There was a problem with your submission. Errors have been highlighted below” and it highlights the credit card information area as if the card information didn’t work and/or go through BUT the charges are being processed on the side as a new charge. Both the API Login ID and Transaction key have green checkmarks, and it’s obviously connected because the charge processes but to the user it appears as if it has not gone through. Any advice would be great. Plugin and add-on are both the more recent versions installed.

Hi AnnMarie. If you have not already, I recommend opening a priority support ticket for this:

Hi AnneMarie,

I submitted the exact same issue to support a couple of hours ago.

This seemed to start happening for us earlier this month out of nowhere.

Have you by chance figured it out yet, or have you heard back from support on a potential solution?

Sorry you’re also dealing with this issue. Hope it gets solved quickly!


I did. They looked at our logs and couldn’t help. They suggested we connect with and our hosting and neither could see a problem on their end so I’m now in the forums to see if any users have any insights.

Hello Jeremy,
No luck yet from Gravity forms support, support or Godaddy support where we are hosting. Right now we’re troubleshooting trying all different things, including different hosting companies we use. Hostgator seemed to work just fine but the site we tested on was using an older version of Gravity forms so I’ll be trying that next. We’re pretty much troubleshooting on our own (and searching forums to see if anyone has any insight on it) since support hasn’t been able to help. If I somehow figure it out I’ll be sure to share the info :slight_smile:

Thank you very much for the reply AnnMarie!
I received a reply from Gravity support, but they indicated it appears to be a communication issue with Authorize.Net even though the payments are successfully posting.

We are using the same setup as you (Gravity, Auth and Godaddy). That makes me wonder if possibly it is some update perhaps that Godaddy posted to the servers that is perhaps not accepting the response from Auth transactions like it used to.

If I find anything at all, I’ll be sure to let you know as well.

Checking the support tickets, the issue is the same for both Jeremy and AnnMarie:

ERROR --> GFAuthorizeNet::authorize(): Funds could not be captured (error_message). Response => Error connecting to AuthorizeNet

That means that the webserver hosting your site cannot connect to Authorize.Net. Please contact the hosting support and see if they can explain why the plugin cannot connect to the URLs provided back in the support ticket replies. Thank you.

I’m still chasing my tail on this one AnnMarie. Have you gotten anywhere at all with it, or are you in the same boat?

I’m still not certain how it is a connection issue if payments are successfully making it into Auth.Net.

The issue seems to be that we are not getting a response from Auth.Net when we are expecting one, so it seems that the plugin treats that as it could not connect at all.

Are you seeing something similar?

Thanks and good luck!!!

Thank you for the reply, Chris.

Is there a reason that the plugin would be able to connect to Authorize to succeed in actually submitting a payment (we can see the payments hitting our Authorize account and charging the user’s cards), but not be able to connect to get a response from the server?

What we found is that the plugin has been creating the “cannot connect” response message we are getting based on the fact that it doesn’t see a response coming back from

I just want to make sure I have as much information as possible when working with GoDaddy.


It’s possible the connection to Authorize.Net for the POST works fine (to submit the charge) but that the server (GoDaddy if that is your web host) is blocking inbound traffic from them somehow or for some reason. It could be a security setting in the hosting configuration.

I have to agree with Chris that the issue is with Godaddy. I tested a payment using Hostgator and successfully was able to process the payment. Same form, I exported it and imported it to a site on Hostgator and all work as it should. Because of that I would assume the issue has to be with GoDaddy. We tried connecting with support and we were told everything was good on their end before we tested using a different hosting company… it looks like that is not the case and we need to connect with hosting support again at GoDaddy.

Thank you, AnneMarie!

I appreciate the information very much.

I too will go to GoDaddy with this information and see where we get.

I’ll let you know what happens!!!


Thank you very much for the reply!

I will go to GoDaddy and see what they have to report on potentially blocking inbound traffic from

Please update us here and I can add notes to the support ticket as necessary. Thank you for sticking with this.

Our client just forwarded us an email from early September stating that GoDaddy had “moved” their site from their old Web Hosting Linux to their new Linux Hosting with cPanel.

I’m going to contact GoDaddy specifically about that to see if the new location is blocking incoming traffic from, or if the server location change could adversely affect the callback.

AnneMarie, did you recently receive any kind of notification about your site being “moved”?


No luck on the moved site. Apparently it was for a different site our client owns and they were confused.

GoDaddy insists nothing changed and says they always send back a response even though the plugin doesn’t believe it ever got one.

Hi AnneMarie,

I hope you are well.

Any luck with figuring out the issue?

We are still experiencing it and GoDaddy insists that they had not changed anything.


Hi AnneMarie,

I wanted to post an update for you and also ask you a favor if you don’t mind sharing.

We have been able to determine what is happening, but have not yet figured out the cause.

We found that the cURL request being generated by the plugin does not function as expected and we don’t get a valid response from

If we issue the exact cURL request from a shell command to the command line from within the code it works perfectly and we get a valid response.

So for now we have a workaround, but want to fix the true issue that is causing it to fail.

We are currently focusing on examining the version of components we have installed in our site and have found that some of the components are older (cURL, libSSH to be specific).

What I’m hoping you would be open to is sharing which versions of those 2 libraries you are seeing in your phpInfo to see if in fact there maybe something to our theory before going forward with any type of upgrade of the components.

If so, we would truly appreciate it and hopefully it leads to a resolution for both of us! :slight_smile:

Kindest Regards,