Line Break Tags in Notifications

Hello, has anyone else discovered a issue with Line Break tags within a notifications email? I have “Disable auto-formatting” checked but if I save and switch from the text editor of notifications to visual, it removes the line breaks. Any ideas?

The only purpose of the “Disable auto-formatting” setting is in fact to stop Gravity Forms adding line breaks automatically. So you would enable this setting only if you don’t want line breaks.

This would be the case if you plan to add your own custom HTML format to the notification content. In this case, you need to create the line breaks with your own custom HTML.

For example, using <p>HTML paragraphs. </p> or <br> tags.

Note that TinyMCE (the editor used by WP and notifications) is known to remove certain HTML tags when switching from Text to Visual, so you may want to remove the Visual tab for notifications to prevent accidental lost of HTML tags, you can do this with the following snippet:

add_action( 'admin_init', 'disable_tinymce_in_gf'); 
function disable_tinymce_in_gf() {
 if ( ( RGForms::is_gravity_page() && rgget( 'page' ) == 'gf_edit_forms' && rgget( 'view' ) == 'settings' ) && rgget( 'subview' ) == 'notification' ) {
  add_filter( 'user_can_richedit', '__return_false' );

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.