Error thrown Wrong parameters for Exception message

I’m receiving the following error message on my website when trying to load new pages, it happens occasionally. Does anyone know why this is happening and how I can fix it?

Error thrown
Wrong parameters for Exception([string $message [, long $code [, Throwable $previous = NULL]]])

AND Here is the information being received in the plugin updates page, in the admin of my site.
Gravity Forms
You have version 2.3.6 installed. Update to 2.4.22. View version 2.4.22 details.
Compatibility with WordPress 4.9.16: Unknown
Compatibility with WordPress 5.6.1: Unknown

AND

Gravity Forms MailChimp Add-On
You have version 4.3 installed. Update to 4.8. View version 4.8 details.
Compatibility with WordPress 4.9.16: Unknown
Compatibility with WordPress 5.6.1: Unknown

Any help would be greatly appreciated.
Kindest regards,
Melissa

Hi Melissa. It looks like you need to update the Mailchimp add-on and also Gravity Forms. Is there a reason you are using versions that are so far out of date? It looks like your WordPress version is terribly out of date as well.

Hi Chris,

Thank you, I have wordpress 4.9.16, I can see that version 5.6.1 is available. I could update it but its an old website, I don’t currently have a web designer and I am managing it myself due to the current environment. Normally the wordpress updates itself after a while. I have a lot of plugins including the Mailchimp add-on and also Gravity Forms, I’m a bit scared to update the wordpress because sometimes plugins stop working.

Its not a new website and I am not a tech minded person so it’s difficult for me to know how to manage it all. Perhaps I should update the wordpress, this is what it’s saying in the admin.

If I do need to purchase, would the basic Gravity Forms $59 annual license cover these or would I need the Pro?

Basically its not letting me update the Mailchimp add-on and also Gravity Forms.

Best regards,
Melissa

I think the version wordpress 4.9.16 that I have isn’t that old.

Hi Melissa. A Basic license will cover Gravity Forms and the Mailchimp add-on. Your versions are very old and you really need to update. This may require the support of someone familiar with WordPress updates, like a developer of a consultant. Normally, with versions that old, you would have a staging site where you can first test the updates to be sure nothing else breaks, like the theme. I recommend trying to find some help with your site, so that things don’t get worse. I recommend checking here if you don’t have anyone local:

Thank you for your help.
Kindest regards,

Thank you Melissa. Good luck.

© 2008 - 2019. Gravity Forms is a project by Rocketgenius Inc.