Pagination throws an tinymce.min 500 error [RESOLVED]

Hey there,
So I have many multiple page forms. Others work fine but I have one with 4 pages that is throwing errors in console when I try to change pages. The errors appear to start with Tinycme.min.js which is odd because that is a WYSIWYG js and has nothing to do with anything on the next page. The following are my console logs when I select “Next”:

tinymce.min.js?ver=4800-20180716:2 POST https://goadrifttravel.com/?gplp=preview&id=35&ajax=1&showhidden=1&unrequire=1 500 (Internal Server Error)
e.submit_patch.o.submit.nodeType.o.submit.length.o._mceOldSubmit.o.submit @ tinymce.min.js?ver=4800-20180716:2
trigger @ jquery.js?ver=1.12.4:3
a.event.trigger @ jquery-migrate.min.js?ver=1.4.1:2
(anonymous) @ jquery.js?ver=1.12.4:3
each @ jquery.js?ver=1.12.4:2
each @ jquery.js?ver=1.12.4:2
trigger @ jquery.js?ver=1.12.4:3
onclick @ ?gplp=preview&id=35&ajax=1&showhidden=1&unrequire=1:1


jquery.js?ver=1.12.4:4 POST https://goadrifttravel.com/wp-admin/admin-ajax.php 500 (Internal Server Error)
send @ jquery.js?ver=1.12.4:4
ajax @ jquery.js?ver=1.12.4:4
j @ heartbeat.min.js?ver=f50854d010ad91aad1dc0fc45f49d777:1
(anonymous) @ heartbeat.min.js?ver=f50854d010ad91aad1dc0fc45f49d777:1
setTimeout (async)
k @ heartbeat.min.js?ver=f50854d010ad91aad1dc0fc45f49d777:1
m @ heartbeat.min.js?ver=f50854d010ad91aad1dc0fc45f49d777:1
n @ heartbeat.min.js?ver=f50854d010ad91aad1dc0fc45f49d777:1
(anonymous) @ heartbeat.min.js?ver=f50854d010ad91aad1dc0fc45f49d777:1
dispatch @ jquery.js?ver=1.12.4:3
r.handle @ jquery.js?ver=1.12.4:3

I’ve tried to find what might be throwing the error by:

  • Removed Conditional Formating - Did nothing
  • Removed Stripe Field - Did Nothing
  • Moved Page Field - Fields from the next page showed fine
  • Removed Page Field - Fields from the next page showed fine

UPDATE

  • I also tried disable my after_submission - Did nothing

Thoughts?

I recommend opening a support ticket for this issue:

https://www.gravityforms.com/open-support-ticket/

Hey Chris (or anyone else),
Soooo I put in the ticket this morning, and of course got no response. BUT I did a lot of poking at it and I think I found the issue. It seems like I had a conflict with trying to calculate two dates. This wasn’t a problem before and I wonder if it came about from one of the recent updates…

I found the problem by incrementally moving the page field until the next page button got hung up… Thankfully, after a lot of trial and error, I was able to do a simple google search to find David’s GW snippet which got me up and going again:

https://gravitywiz.com/calculate-number-of-days-between-two-dates/

Now I just need to undo all the damage I did to try and find the error in my form :confused:

That’s a good troubleshooting tip! I’ll make sure your support ticket is updated with these notes.

© 2008 - 2019. Gravity Forms is a project by Rocketgenius Inc.