Check Boxes display across screen [RESOLVED]

Hello,

My check boxes are displaying full width across the screen and I do not know how to fix. When I view through the Form view they display correctly. But, when I add to my page, they display all the way across the screen. Any help would greatly be appreciated.


Thank you,
MonaE

Can you share a link to the page on your site where we can see the form? It looks like the theme or a plugin is applying custom styling to the inputs. We’ll need to see the form on the page to see what is happening. Thank you.

1 Like

Sure, the link is:

Thank you.

Hello. You theme is applying a width of 100% to the inputs, and hiding the default browser styling, in this file:
https://naiopsac.org/wp-content/themes/wego/css/main.min.css?v=1.0

You can see the styles in this screenshot:

To override that for these checkboxes, you can add this CSS to your theme (or child theme) stylesheet or via the Appearance Customizer (Appearance > Customize > Additional CSS):

body .gform_wrapper input[type="checkbox"] {
  width: 20px;
  appearance: checkbox;
  -webkit-appearance: checkbox;
}

This is what your checkboxes look like when I apply that to your form:

If you need anything else, please let us know.

Thank you Chris, that worked :blush:.

MonaE

1 Like