Bug Gravity Forms 2.5 removing numbers [RESOLVED]

I’m testing updating from 2.3 to 2.5, but have an issue where numbers are getting removed from the field when I attempt to the next page. No error is thrown

I have html5 fields turned on and it works fine in 2.3
The number field is set to have a comma, and any 4 digit number is removed.

Works fine:
20
200
999

Gets removed:
2000
2,000

Wrongly doesn’t get changed to a comma:
2.000

Thanks
Will

PS. I’m not sure why we can’t have the option of no number formatting

Which currency is selected on the Forms > Settings page?

US dollars, I tried Pound and Australian Dollars and got the same result.
I’ve now noticed that if I change the format to “9,999.99” the input type=number
Where as if it’s “9.999,99” type=text

Hi Will. I recommend opening a support ticket here so we can dig in.

Thank you.

Thanks Chris, I’ll do that.

I’ve worked out that is a Plugin called “Gravity Forms (Word) Documents” and this line, if I remove this or change it to false it works fine:

add_filter( 'gform_include_thousands_sep_pre_format_number', '__return_true' );
© 2008 - 2021. Gravity Forms is a project by Rocketgenius Inc.